Weird bug

Endercraft

Active member
I just got a weird bug where I got back to Macrodroid another macro actions replaced the macro actions I was working with. The macro still has it's name and when I save it it says there's aldready a macro with this name. Has anyone experienced this? It seems to happen on the latest version.
 

dhj49er

Active member
No, not experienced anything like you describe.
Could you post here the macros that have the issue?
 

Endercraft

Active member
I don't remember what macro it was but I know accessing Macrodroid from recent apps can cause weird thing, like dark mode going crazy and thinking it's dark and normal at the same time which make letters very hard to see.
 

chaoscreater

Active member
Not sure if we're talking about the same bug here, but sometimes if I click on the "Run Macro" action, it'll take me to the wrong macro.

For example, let's say I have a Run Macro called "ABC Test". When I click on this action, it should take me to the macro called "ABC Test". Instead, it takes me to a different macro called "123 Test". And sometimes, it'll take me to the correct macro, but the name of the macro will be different.
 

Endercraft

Active member
No, not experienced anything like you describe.
Could you post here the macros that have the issue?
I finally managed to capture the issue :
Screenshot_2022-09-24-22-17-20-757_com.arlosoft.macrodroid.jpg
This is the macro that has the issue (same name but copied content from another macro)
Screenshot_2022-09-24-22-18-49-716_com.arlosoft.macrodroid.jpg
(This is the macro that the contents were copied from)

This happened after a macro name issue, when I decided to make it VERY VERY long, which made MacroDroid unresponsive. After opening it back the issue happened.
 
Top